Showing posts with label MAPI. Show all posts
Showing posts with label MAPI. Show all posts

Thursday, 1 August 2019

Gmail и отложенная отправка почты.

Всем привет.

Не знаю как давно, но в Google Gmail появилась отложенная отправка почты. Очень полезная фишка, которая мне нужна была много лет тому назад. Теперь она есть. Ура! 


Теперь я могу любые письма к определенной дате (Новый год, например) написать прямо сейчас, выставить время отправки и... забыть про них.

Вот такая вот мелочь, а приятно.

Wednesday, 15 November 2017

Бизнес-аспект почтового спама.


Всем привет.

На днях вычищая свой корпоративный почтовый ящик обнаружил интересное сообщение в котором автор потрудился заверить меня что это точно был не "Спам".

В начале по тексту, как обычно, было рекламное предложение, а вот и сама концовка:

Полученное Вами электронное сообщение не является «Спамом» по следующим причинам:

1. Бизнес-аспект
Данное электронное сообщение является коммерческим предложением и адресовано на полученный из открытых источников электронный адрес <nul>. Под открытым источником подразумеваются деловые справочники, такие как «Желтые страницы Украины», «Бизнес-досье», «УкрБизнес» и д.р. Добавление Вами контактной информации в эти издания предполагало нахождение новых партнеров посредством телефонной, почтовой или e-mail связи.

2. Законодательный аспект
Полученное Вами электронной сообщение не является «Спамом», так как полностью отвечает требованиям Постановления КМУ No. 720 от 09.08.2005 г. и ст. 33 Закона Украины «О телекоммуникациях», не попадает под ст. 363-1 УК Украины.

3. Технический аспект
Полученное Вами электронное письмо содержит все необходимые специальные технические заголовки, рекомендованные крупнейшими мировыми почтовыми системами Google Mail, Yahoo Mail и Live/Hotmail (SPF, Precedence, List-Unsubscribe, DKIM/DomainKey, Sender-ID), а также отвечает спецификациям RFC 2822, RFC 2369 и RFC 2919.

4. Аспект Сетевого этикета
Письмо было отослано со специально созданного ящика, адрес которого в явном виде присутствует в заголовках письма, т.е. адрес отправителя — реальный, а не подставляемый, как в случае «Спама». Письмо также не содержит вирусов, фишинга и никаких других мошеннических уловок.

Автор письма постарался, сразу видно. Я могу заглянуть в ст.363-1, могу проверить служебные заголовки сообщения согласно спецификаций RFC и даже согласиться с сетевым этикетом. Но есть одно Но - я как частное лицо не размещал свой электронный адрес (адрес получателя в сообщении) в открытых источниках! Если вы уже так волнуетесь за свою информацию извольте добавить и адрес открытого источника в котором был "найден" мой электронный адрес в параграф Бизнес-аспекта. Я проверю, и тогда поговорим.

А пока это Спам, как ни старайся.)

Всего хорошего.



Thursday, 14 July 2016

Microsoft Outlook - отложенный старт отправки.

Всем привет.

Не так давно я вам рассказывал про отправку писем с помощью PowerShell. Обычное дело.

Но представим себе пользователя который не искушен в PS-скриптах. Для приема  и отправки электронной почты он пользуется обыкновенной MS Outlook.

Если вам требуется, что бы электронное письмо отправилось адресату в назначенный день и час, то в программе Microsoft Outlook имеется возможность запрограммировать время и дату отправки вашей корреспонденции. Так называемый отложенный старт. Но для этого в назначенное время и дату ваш ПК должен быть включен, запущена программа Microsoft Outlook и иметь доступ в Интернет.

Но это письмо будет отправлено единожды!

А если вам надо его отправить повторно, но в другое время? Для этого придется писать скрипт VBA. Ибо MS Outlook хоть и хороший клиент, но не настолько.  Не пугайтесь, вы не первый.  Вот здесь другой автор предложил скрипт(макрос) который в заданный интервал времени (раз в сутки, в среду вечером, раз в неделю или в иное указанное время) отправляет письма из указанной папки Outlook. При этом данные письма не удаляются, а служат своего рода шаблоном. То есть один раз создали письмо-шаблон и в заданное время без вашего участия будет происходить его отправка. Вот сам макрос:

Private Sub Application_Reminder(ByVal Item As Object)
    Dim OutFolder As Folder, NewItem As MailItem
    If Item.Subject = "Letters Delivery" Then
  Item.MarkComplete

        'Set OutFolder = GetNamespace("MAPI").Folders("Иванов Иван Иванович").Folders("Расписание")
        Set OutFolder = GetNamespace("MAPI").Folders(CStr(Session.CurrentUser)).Folders("Delivery")
     
        'перебираем письма в указанной папке
        For i = 1 To OutFolder.Items.Count
            'Debug.Print OutFolder.Items(i).Subject     'тема письма
            Set NewItem = OutFolder.Items(i).Copy       'создаем копию письма
            Call NewItem.Send                           'отправляем письмо
        Next i
    End If
End Sub

Wednesday, 20 May 2015

The Bat! и MS Exchange - дружба или нет?


Всем привет.
Недавняя история. Был повод размяться...

Коллега на работе переехал своей электронной почтой под сервер MS Ecxhange. Разумеется по умолчанию ему дали клиента MS Outlook 2010. А он так любил пользоваться The Bat!). Поскольку на его работе никто The Bat! не юзал он попросил меня настроить его мыша на новый сервер.

А что мы теперь за протокол используем? Конечно же MAPI.

Пару слов о MAPI (Messaging API). Это интерфейс и это набор структур и функций, которые необходимы для доступа к почтовому транспорту и хранилищу данных без конкретизации, какой именно почтовый клиент используется.  Почтовые клиенты реализуют стандарт MAPI в виде dll (обычно это mapi.dll или mapi32.dll). Тогда в любом приложении разработчик может предусмотреть функцию отправки текущего файла по почте с использованием Вашего почтового клиента по умолчанию, не вдаваясь в детали ваших интернет-настроек. На текущий момент существуют два стандарта: Simple MAPI (12 функций) и Extended MAPI, или MAPI 1.0 (более 100 функций). 

Поддерживает ли The Bat! MAPI?
На официальном сайте The Bat! сказано что Да.
На неофициальном ответ: и да, и нет.

Начал разбираться.
The Bat!, начиная с версии 1.47, поддерживает запросы по Simple MAPI, хотя MS Outlook поддерживает оба интерфейса.  Насчет необходимости: если бы интерфейс Extented MAPI был реализован в The Bat!, тогда автоматически отпал бы вопрос о TheBat API, о котором иногда просят разработчиков. Любые плагины стали бы возможны. Теперь во что это выливается практически. Существование (поддержка) интерфейса MAPI обеспечивает возможность не почтовым программам реализовывать то самое меню "File -> Send". Если есть в системе почтовый клиент, который установлен как MAPI-клиент, значит файл отправиться, нет — значит нет. Большинство программ, например: FreeHand, Mathematica, WinEdt, WinZip, etc. поддерживают Simple MAPI, поэтому они нормально вызывают The Bat!. Так как приложения Microsoft Office изначально ориентированы на внутреннюю интеграцию, то и в качестве почтового клиента они ожидают MS Outlook. В меню "File" приложений Офиса может присутствовать команда "Send"(отослать текущий документ), это зависит от настроек при установке Microsoft Office. Если в этом меню есть опция "Mail recipient (as attachment)", то в случае ее выбора будет вызван почтовый клиент по умолчанию. Так что TheBat! сформирует письмо с вложением. Все остальные опции этого меню будут предназначены именно для MS Outlook и другой почтовый клиент не будет вызван. 

Для того чтобы использовать в The Bat! MAPI DLL советуют сделать следующее.

Версія на друк

Популярне