А АFriday, 4 March 2016

Поиск ccылки на ячейку в MS Excel.

Всем привет.

При обработке некоторой таблички в MS Excel возникла простенькая задача - надо было найти все формулы в которых участовала определенная ячейка. Ммм, попробуйте далее не читать и решить ее самостоятельно.

Ну а кому не втерпеж, слушаем далее. Итак для примера мне надо найти кто использует ячейку B4.

Первое решение - используем поиск. Указываем ячейку в поиске и нажимаем "Найти все". В результате имеем список всех ячеек где наша B4 участвует в расчетах. Для чего не подходит такой способ? Это не подходит в случае, если наша ячейка участвует  в диапазоне типа "=СУММ(B3:B7)" или ссылка абсолютная "=B$4".



Решение второе - используем "Зависимости формул". Ух ты, какая фишка есть в MS Excel. Закладка "Формулы -> Зависимость формул -> Зависимые ячейки" и MS Excel сам показывает где участвует наша ячейка. Красиво правда? Согласен.


Однако есть небольшое ограничение. Если ваша ячейка на другом листе, то MS Excel покажет только наличие зависимости, но не скажет на каком именно листе книги находится искомая формула. Пишите макрос.

Такие дела. Успехов.

No comments:

Post a Comment

А что вы думаете по этому поводу?

Версия на печать

Популярное

Медиа облако